Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

Sending message returns nothing, then spills events on general chat room seconds later

Description

This is a chat server that used to work, but stopped operating correctly today. The version is outdated, I’ll try and upgrade it to the latest to see if a similar issue pops up.

First, I try to attempt to send a chat with “sendChattingMessage” through the websocket

This is the result. It does not return the corresponding message.

Few seconds later, so many stream-notify-user messages are coming. Note that the room for this event message is NOT the room I sent to with sendChattingMessage (it says _id : “GENERAL”, so I’m suspecting it is a general chat room).

I would like to ask if this was a known problem that was fixed in the later versions. I think we had encountered this very issue previously, but was solved simply by restarting the server. But I don’t think a server restart should be a solution to any problems, hence

Also, is GENERAL chat room necessary? We don’t particularly use it in our case…

Server Setup Information

  • Version of Rocket.Chat Server: 3.11.0-develop
  • Operating System: Ubuntu 20.04.1
  • Deployment Method: docker

Hi!

I suggest you to spin up a staging environment, restore a backup from production, and upgrade to latest version. Then experiment with your integrations.

A lot has changed since the version you are using. If we can find out that the problem was solved on latest, we got a solution.

If not, we’ll need to come up with a way to consistently reproduce this error on latest so we can scale this up with our team.

thanks!!

My bad, the sendMessage not working correctly was because of our error (we use a different filtering logic for bad words…). Sorry for not checking.

May I ask, though, what that stream-notify-user event is for? I wasn’t able to find it in the documentation…

1 Like

Glad you were able to solve it :slight_smile:

Here is the docs for this sub:

I meant stream-notify-user/rooms-changed. The event messages that I’ve posted. What is causing them to spill those messages?

The documentation about these notify messages and how they can be triggered is IMO a little lacking in details…

I’m guessing maybe a room is added or something, but I can’t be sure…