RocketChat: Multiple setup and mongo db restore issue

I am new to RocketChat so having limited knowledge about the same. I have couple of queries related to mongo restore and multiple RC setup into different folder.

  1. I want to setup one rocket chat docker container for one domain <> and another rocket chat container setup for another domain <> on Single EC2 linux instance. We have maintaining docker-compose files at two different folders for above two domains. Used below settings in docker compose files.
    a) Different rc service name and host ports
    b) same mongo service name in both compose files
    c) different mongo database names for two setups.
    d) Using same oplogurl and mongo url in compose files.
    With above settings we observed that database get created in mongo db container spin up in example1 folder when we tried to do setup for example2. Also when we tried to down example2 containers then that time mongo service also goes down. we have tried to different ways by specifying different network name in compose files. We are not able to understand the behavior of mongo service and its replica set.

  2. We have configured one RC docker container setup, provided org level information, admin user created etc. and taken backup of mongo database using below backup command. But when we have tried to restore the same db on another instance using below restore command then it displays organization setup wizard page again to do all the RC setup from scratch. As per our understanding this should not be happen as we have already done entire setup.
    Backup command = docker-compose exec -T mongo bash -c ‘mongodump --archive --db=db1’ > db1.dump
    Restore command = docker-compose exec -T mongo bash -c ‘mongorestore --archive --db=db1’ < db1.dump

Server Setup Information

  • Version of Rocket.Chat Server: 3.6.0
  • Operating System: Linux
  • Deployment Method: docker - Using latest rocket chat image tag
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 12.16.1 - x64
  • MongoDB Version: 4.0.20
  • Proxy: nginx
  • Firewalls involved: No

Your quick help is appreciated.