Rocketchat in Virtualbox and local:3000 on host

I installed rocketchat on ubuntu server on virtualbox.

I couldn’t access the http://localhost:3000 page after installation.

The solution was to go to Machine>Settings>Network and changing the Attached to: from NAT to Bridged Adapter, and click ok to save configuration.

I restarted the server, and on the host machine I was able to access to configure rocketchat as admin.

Unfortunately I haven’t had success with port forwarding out of virtualbox. I have attempted to make a rule for Port Forwarding with the following configuration

Name: anything really
Protocol: TCP
HostIP: blank which is the equivalent to allowing any machine to connect.
Host Port: 3000
Guest IP: blank
Guest Port: I tried 80, 8080

no luck. If anyone figures this out that would be handy to run the vm with NAT network setting.


If you installed on a virtualbox, the URL where to access will depend on configurations about that machine.

What you can do is to set the network to bridge mode. That way, it will have it’s own IP.

You can then access: http://IP.OF.THE.VM:3000

let me know if this helps :slight_smile: