Port 3000 not open on server


I can connect to my rocketchat through LAN but I can’t when I’m not connected to Wifi. I’ve tried adding firewall rules and using other devices. It just refuses to connect regardless of what I do.

Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System:
  • Deployment Method:
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy: none
  • Firewalls involved: none

Any additional Information

Can you clarify your description?

Did you mean:

I can connect to my rocketchat server when connected to my LAN via ethernet cable, but I cannot connect when connected to my LAN via WiFi.

Are you connecting from the same computer when attempting to connect via ethernet and attempting to connect via WiFi? Using the same URL to connect in both cases? Are you getting the exact message that you stated ibn your subject line “Port 3000 not open on server” ? What what software?

So I have the rocket.chat server running on an old laptop and I’m using my desktop to connect to it through Ethernet and Wifi which both work but as soon as I try using a network that isn’t my home network, it refuses to connect. I tried using one of those port checker websites and it says that port 3000 is not open, even though it has an exception in the firewall on the server. I am not using the same url each time to connect, I tried using both the private and public IP to connect, the private IP works only when I’m on my home network, and the public IP does not work at all.

In addition to opening port 3000 in the firewall on the server, you will need to forward port 3000 on your router to port 3000 on the server, if you want to access the server from outside your home network. https://portforward.com/router.htm