RocketChat ERROR --> Cannot read property "indexOf" of undefined


Server Setup Information

  • Version of Rocket.Chat Server:
    → version 3.7.4 (1.18.0)

  • Operating System:
    → UCS 4.4-8 errata974

  • Deployment Method:

  • Number of Running Instances:

  • DB Replicaset Oplog:

  • NodeJS Version:

  • MongoDB Version:

  • Proxy:

  • Firewalls involved:

Any additional Information

Hi - Rocket.Chat is new to me. Just set up a new system as an replacement for Mattermost last week. My installation is based on the Univention plattform.

The installation worked fine - my “only” issue is, that I’m unable to import users via the LDAP connector. An import of 4 users worked 50%. Means all for are imported - but just two are working.
Even if I break the LDAP link, I’m unable to delete the imported users.
I have posted already something to the UCS forum, but looks like, no-one form Rpcket.Chat is picking it up.
Her is the Link:

Hope to here someone who can assist.
Thank you in advance

Hi - just haven’t seen any feedback. Is any information missing or is it something I’, doing wrong?

Any feedback is more than welcome :wink:


Sorry but I don’t frequent their foros!

OK, this may well be an issue with the version you are using. We are literally in the process of upgrading the Univention install but have hit a bit of a roadblock which we are trying to resolve.

LDAP is tricky though most use it successfully. I think you need to sync the LDAP user with Rocket users (check the admin panel) but do all the control from LDAP, not Rocket.

Remember, if they are deleted then you are expecting Rocket to deal with all their messages, not just them as a user, so it isn’t quite as simple as it seems.

I have a feeling that you can’t delete in LDAP and expect the Rocker users to disappear, and there may have been an issue deleting them in Rocket - I have a feeling that was a fix in a later version. A search in github may reveal more.

Hi John - thank you for coming back to me.

Maybe some more background helps to understand where I’m.

I just stated with Rocket.Chat - that means, the 4 enabled users are just test users. The 4 has been added to the one and only room (channel) - and removed from the admin (both times). one of these users has posted anything.

On the Univention end, I have deaktivaded the users in the UCS management

Means the users accounts are still there on the Univention end (and in LDAP).

The only way I found to check if the LDAP link is working between Rocket.Chat and Univention is via the Rocket.Chat admin panel:

Anyway - I will reinstall the Rocket.Chat server to start from beginning. To run not into the same issues - could you please let me knoe the steps on how to integret the Univention users into the Rocket.Chat server.



No worries. As I mentioned we are trying to update the Rocket install but hit a bit of an issue. So the version you have is a bit out of date…

I am not sure on the exact steps as I am away from my normal workspace so can’t get to my test Univention install, nor do I have any experience with their LDAP setup…

The main thing is making sure the LDAP syncs, and you have admin fallback to a local user. Check the admin settings for that.

So on my own servers (non Univention) I do not create any local users apart from a LOCAL admin user. All the rest sync from LDAP. Don’t try and delete any - just change the password/disable if they are not required.

Have a good play to see what you can and cannot do. I think there are enhancements once we get you upgraded to 3.14/3.15 that will help.