Can't Register Workspace in Rocket Cloud && Helm Chart installation


Hey guys ! :wave: Greetings from :chile: !

I installed RocketChat using the Helm Chart application. But I can’t register the Worspace in the Rocket Cloud. I tried the Offline registration, but it can’t sync:

I checked the logs (“View logs” section), but it did not showed anything relevant.

Server Setup Information

  • Version of Rocket.Chat Server: 5.3.2
  • Operating System: Docker image (
  • Deployment Method: Rocketchat Helm Chart
  • Number of Running Instances: 1
  • NodeJS Version: 14.19.3
  • MongoDB Version: 6.0.3
  • Proxy: traefik
  • Firewalls involved: No.

Appreciate any hint or advice on how to debug the error !

Thank you :pray::pray::pray:

Any additional Information

I am using Cloudflare and Traefik as a reverse proxy.

I checked the Chrome console, but it did not showed any error.

This is the values.yaml file I used for the helm deployment:

clusterDomain: marketshop.local
  enabled: true
  username: yyyyyyy
  password: zzzzzz
  port: 587

externalMongodbUrl: mongodb://mongodb:xxxxxx@mongodb.databases:27017/rocketchat
externalMongodbOplogUrl: mongodb://mongodb:xxxxxx@mongodb.databases:27017/local?replicaSet=rs0&authSource=admin

  enabled: false
  enabled: true
#  storageClass: nfs-client
  enabled: true
  annotations: traefik websecure
    - host:
        - path: /
          pathType: ImplementationSpecific
  path: /
  type: ClusterIP
  port: 80

Rocketchat info details:

Could you try with mongo 5?

Thank you @debdut.chakraborty

Just tried with Mongo 5, but I got the same result :frowning:

The log shows the following after the Pod restarts:

strict mode: use allowUnionTypes to allow union type keyword at "#/properties/value" (strictTypes)
LocalStore: store created at 
LocalStore: store created at 
LocalStore: store created at 
MessageType.render is deprecated. Use MessageType.message instead. livechat_webrtc_video_call
{"level":40,"time":"2022-12-26T14:24:24.693Z","pid":1,"hostname":"rocketchat-chat-patagon-rocketchat-7bc99b4f4f-hpqnl","name":"VoIPService","msg":"Voip is not enabled. Cant start the service"}
{"level":40,"time":"2022-12-26T14:24:26.840Z","pid":1,"hostname":"rocketchat-chat-patagon-rocketchat-7bc99b4f4f-hpqnl","name":"VoIPService","msg":"VoIP service already stopped"}
{"level":51,"time":"2022-12-26T14:24:27.059Z","pid":1,"hostname":"rocketchat-chat-patagon-rocketchat-7bc99b4f4f-hpqnl","name":"Migrations","msg":"Not migrating, already at version 281"}
Change Stream is available for your installation, give admin permissions to your database user to use this improved version.
[DatabaseWatcher] Using oplog
ufs: temp directory created at "/tmp/ufs"
=== UnHandledPromiseRejection ===
Error: $MONGO_OPLOG_URL must be set to the 'local' database of a Mongo replica set
    at server/database/DatabaseWatcher.ts:94:10
    at /app/bundle/programs/server/npm/node_modules/meteor/promise/node_modules/meteor-promise/fiber_pool.js:43:40
Errors like this can cause oplog processing errors.
Setting EXIT_UNHANDLEDPROMISEREJECTION will cause the process to exit allowing your service to automatically restart the process
Future node.js versions will automatically exit the process
Loaded the Apps Framework and loaded a total of 0 Apps!
|                  SERVER RUNNING                 |
|                                                 |
|  Rocket.Chat Version: 5.3.2                     |
|       NodeJS Version: 14.19.3 - x64             |
|      MongoDB Version: 5.0.14                    |
|       MongoDB Engine: unknown                   |
|             Platform: linux                     |
|         Process Port: 3000                      |
|             Site URL:  |
|     ReplicaSet OpLog: Enabled                   |
|          Commit Hash: 215a0685a5                |
|        Commit Branch: HEAD                      |
|                                                 |

It seems there is something wrong with the OPLOG_URL …checking…

Well…I finally used Mongodb version 4.4.11 (instead of Mongodb 6 and 5) and it worked !

I used the default Helm settings for the mongodb database.