Odd handbook advice broke cloud/notifications


I received an “error processing your request” in rocketchat and so I followed this article in the handbook, deleted database entries like so db.rocketchat_settings.remove( {"_id": /Cloud_/} ) and restarted. Then I realized I don’t even know what fleet commander is, how I could “Regen Initial Token” and since then, notifications don’t work although both in cloud.rocket.chat and on the server everything seems fine and even the “sync” operation in the workspace registration dialog says it’s successful.

Server Setup Information

  • Version of Rocket.Chat Server: 6.2.3
  • Operating System: Linux
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: v14.21.3
  • MongoDB Version: 5.0.15
  • Proxy: nginx
  • Firewalls involved:

Any additional Information

I’ve tried deleting and re-registering the workspace in the cloud console, removing and re-creating the docker containers, restarting the server multiple times, setting “Show Setup Wizard” to pending then restart to do the setup wizard again. I started Cloud Enterprise trial in hopes it would fix the issue or that the “Regen Initial Token” Button would magically appear somewhere but nothing changed a thing.

I’m certain that it’s not an issue with my android device because none of my users are receiving mobile notifications and the counter in the rocketchat cloud isn’t counting any notifications either.

I ran the command db.rocketchat_settings.remove( {"_id": /Cloud_/} ) again, this time with the rocketchat container shut down, now it gets more weird

I cannot remove the duplicate workspace either:

Hi @peh if possible what is your workspace address? If not, can you open a ticket in https://desk.rocket.chat? So we can regenerate your token and just let us know when you have sent the email and the email address where you sent it and we can track it.

If you don’t know how to do this, just send an email to support@rocket.chat and let us know the email address where you sent it for better follow up. Best!

Hey @lester.coyoy thank’s for getting back to me. So I understand that I cannot solve is issue from my instance but it’s an issue with the cloud servers?

I created a ticket:

Just a tiny update from the support ticket: Inserting the token kindly supplied by the support team didn’t help so if any other possible solutions pop up here, they’d be more than welcome! :slight_smile: