Problem Websocket reverse proxy synology

Hey all!

I hope you’re well and healthy. I com to you as I have been struggling with my installation for more than a week now. To give you some contexte, I recently installed through sanp a server on a raspberry pi 3 (version 3.0.1) using the arm64 Debian distrib (not raspbian which is based on armhf). It worked like a charm almost readilly. I was not my first Rocket.Chat installation (did one at work), and after some configuration, I can use it perfectly. This first server is located on my LAN behind a nginx reverse proxy hosted on my Synology NAS. No special config here. I just added the dedicated routes to the server, and voila. Then for a local association, I wanted to install a second Rocket.Chat server on another raspberry pi I have at home, and I am facing an issue with websockets. I can see this issue only when I try to connect to the server on my iOS mobile devices. I get the following error message: “Oops! Websocket is disabled for this server. Please contact your server admin.” As far as I can remember I performed the installation of the second server the exact same way as the first one (by the way I tried several installation before coming here).

To see if it could come from a problem with the dedicated domain name, I change the config on my reverse proxy to make my first domain name (the one used with my working instance (server n°1) pointing to my second server (server n°2). The same problem appears. I precise here that for both domains I have a Let’s Encrypt ssl certificate. When I put it back toward server n°1 still no problem connecting on iOS. So it seems to come from the server n°2 itself and its configuration.

I looked through internet extensively about this issue, and while there are several threads regarding such problem, there is no clear solution proposed (as far as I could see). More I still do not really understand what is websocket and how I can make my server support it. I precise that for both installations I didn’t register to Rocket.Chat services as I do not really need push notifications and prefer to avoid using the server for something that other may need more than me.

Then if you have any idea, or if I shall add some details about my problem, I’d be very happy to have some help.

Have a nice and healthy day!

Server Setup Information

  • Version of Rocket.Chat Server: 3.0.1
  • Operating System: Debian 10
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version: 3.6.17
  • Proxy: nginx (synology webstation)
  • Firewalls involved: No

Ok, I don’t know how but I just went accros this article that solves the problem:

Really sorry for disturbing. This thread can be closed (can I close it myself?).

Thanks for sharing the solution. Might come in handy for others.