Omnichat Appearance, can't save settings


I’m attempting to use the Omnichat feature to add live chat to our internal help desk, I’d be the only user in my Rocket.Chat instance.

I’m having trouble with settings “not sticking” when I attempt to save them, I don’t want the “offline form”, and I don’t want the “registration form”, but if I toggle either to off, they immediately turn back on.

I’ve reinstalled Rocket.Chat many ways, but the issue persists unless I go back to the snap of 4.x, which let me save my settings, but then I couldn’t figure out how to make the live chat embed actually “work” (there was just nothing on the page where I attempted to embed it, where using the same method on 6.x “just worked” )

As far as my Rocket.Chat version, I’ve attemped the Ubuntu Snap in a VM, checking the rocketchat-server option during an Ubuntu Server 22.04 install, the snap on a Debian VM, installing via Docker on Ubuntu, Debian, and CentOS VMs, installing the unsupported Windows docker version, installing using the “Deploy on Ubunbu / Debian / CentOS” methods listed, with the correct versions of node and mongodb installed that the release page on github suggests.

After having no luck with ESXi as my hypervisor I tried again with Hyper-V as my hypervisor, tried again with Proxmox as my hypervisor (and again on proxmox with all of the previously listed options as containers instead of VMs when VMs didn’t work), and a last time with XCP-ng as my hypervisor, after moving on to just trying all of the above a last time with the OS installed to bare metal and no hypervisor installed.

Server is a Dell PowerEdge R940, two Xeon Gold 5217 CPUs at 3.0ghz, and 128 GB of RAM, so I feel like I’m well above what I “should” need to run it.

Everything else about Rocket.Chat seems to work fine, saving Omnichat appearance doesn’t work until I go back to an ancient version, which I also hoped maybe I could start at Rocket.Chat 4.x and work my way up to latest/stable, which kind of worked, but as soon as I get above version 4 the options that I had toggled to “off” change back to “on”, and don’t let me turn them off.

What should I be doing to turn these options off instead of moving the slider to “off” and clicking the save button?

EDIT/ UPDATE: I’ve also tried with and without reverse proxies, and installing GUI desktops on the machine I’m installing Rocket.Chat on, but it doesn’t seem to matter if I’m viewing the admin panel from host.domain.tld, or from 10.0.RC.IP, or from localhost:3000, I’ve been unable to save settings in any of those setups.

Hello, i have the exact same issue !
Some other settings in appearance are also broken …
Please help

UP ! UP ! UP ! UP ! UP ! Please

UP ! UP ! UP ! UP ! UP ! Please