Unable to see (or even activate) live chat in admin


Good morning,

Maybe I’m overlooking the obvious, but i can’t see how or where to activate the live chat anywhere in the administration. According to the docs it should be in “Administration > Settings > Livechat” but i don’t have “Settings” nor “Livechat” anywhere. Is there some kind of secret checkbox that has to be toggled or something like that?

Thanks for any help you guys can offer!

Server Setup Information

  • Version of Rocket.Chat Server: 3.1.1
  • Operating System: CentOS 7.7.1908
  • Deployment Method: tar
  • Number of Running Instances: 1
  • DB Replicaset Oplog: enabled
  • NodeJS Version: 12.14.0
  • MongoDB Version: 4.0.18
  • Proxy: Apache

Any additional Information

Nothing special, standard installation accordion to https://docs.rocket.chat/installation/manual-installation/centos

i have exactly the same problem.

Yesterday i installed ubuntu server 20.04 on virtualbox - and on that i installed rocketchat via snap package (Version 3.2.2). I did so to try out the mentioned Livechat feature.

But as dkuebler describes - the Livechat can’t be found in the settings, as described in https://docs.rocket.chat/guides/administrator-guides/livechat

Settings with L that you can find on my install are:
LiveSteam & Broadcasting

Would be great if anyone could give us a hint there.

Edit - i think i found it (still playing around with the function - not tested):
Go to Admin-> Settings-> Omnichannel
there is a Live Chat Tab there.

Also in those settings if you enable Omnichannel + save - and leave admin settings afterwards - you see that an Omnichannel option is added in the menu you used before to enter the admin settings.
Click that and you got some more Live Chat options. Those look like the settings described in the docs linked above.

Wow, you’re a genious! Enabled Omnichannel and voilà, everything works now, including the live chat on a separate page. Thank you!!