New Android app not working with on-prem installation


#1

The old Rocket.Chat+ Android-app had no issues connecting to my rocket.chat server installed on-prem, version 0.63.0.
The new version gives me this error right after pressing “Connect”, before providing username/password:
ERROR Use JsonReader.setLenient(true) to accept malformed JSON at path $

I see the same error message in this issue here: https://github.com/RocketChat/Rocket.Chat.Android/issues/1057

Anyone have any tips on this?


#2

@teecee Thanks for opening the issue!

This is because the version of your server is too old and you’re not using the latest version of our Android app.

Here’s what you can do to solve it:

  1. Update your server to 0.63.3;
  2. Make sure you’re running latest version of the Android app (2.0.2 now); You can check the version of the app going to Settings -> About under the left sidebar menu;

Let me know if that works for you please.


#3

@rafael.kellermann I just updated to 0.63.3 now, and I’m running the latest version from Play Store (2.0.2), and I still have the issue.

I’m running the server on OpenShift with a custom Docker-image, building from source. It’s behind reverse-proxy with https.


#4

Never mind… It’s mod_security blocking… I have removed 5 rules by now, and it’s still firing new rules… Mostly “SQL injection anomaly”


#5

@teecee I’m glad you found a way out… can we close this issue now?


#6

Yeah, it’s working now.

However, you guys should take a look at how it works behind mod_security. It’s firing a lot’s of rules in the likes of “SQL Injections”.


#7

Server upgrade to version 0.63.3 worked for us regarding the error mentioned above.

On some devices I had to reset application data and reconnect to the server for this to work.


#8

I have just downloaded the latest Android app. I could not figure out how to start a video call nor can I accept a video call from the app. Is it the case that the current version does not support video call? If not, is this feature going to be supported at some stage in the roadmap?


#9

Currently mobile application doesn’t support video/audio calls. They’re in the roadmap to our Q3 at the moment.