Mongodb: No Space Left on Device


Today, October 17, 2023, I found that I wasn’t able to log into my Rocket.Chat instance. When I went to the URL and input my creds I was met with a loading screen that never ended. I ran a docker ps command and found that the mongodb container was continuously restarting. I looked into the logs using docker compose logs -f mongodb and found the following message:

rocketchat-mongodb-1 | mongodb 18:18:32.42 Welcome to the Bitnami mongodb container rocketchat-mongodb-1 | mongodb 18:18:32.43 Subscribe to project updates by watching rocketchat-mongodb-1 | mongodb 18:18:32.43 Submit issues and feature requests at rocketchat-mongodb-1 | mongodb 18:18:32.43 rocketchat-mongodb-1 | mongodb 18:18:32.43 INFO ==> ** Starting MongoDB setup ** rocketchat-mongodb-1 | mongodb 18:18:32.45 INFO ==> Validating settings in MONGODB_* env vars... rocketchat-mongodb-1 | mongodb 18:18:32.47 WARN ==> You set the environment variable ALLOW_EMPTY_PASSWORD=yes. For safety reasons, do not use this flag in a production environment. rocketchat-mongodb-1 | mongodb 18:18:32.49 INFO ==> Initializing MongoDB... rocketchat-mongodb-1 | /opt/bitnami/scripts/ line 449: echo: write error: No space left on device
I’ve had this issue previously and I needed to clean up some old images, but I only have two images stored now and I cannot remove either. I am running on an AWS EC2 instance and I can see that the disk itself has plenty of space. I’m not sure how to fix this issue…

Server Setup Information

  • Version of Rocket.Chat Server: 5.3.6
  • Operating System: CentOS
  • Deployment Method: Docker
  • Number of Running Instances: 1
  • NodeJS Version: 12.22.1
  • MongoDB Version: 5.0.21
  • Proxy: Nginx

Any additional Information

Yesterday, I moved the File Upload from the default to an AWS S3 bucket, but I’m not seeing any errors related to that…I have tried running docker compose down and then bringing it back up, but nothing seems to work. Any help would be appreciated.