Messages greyed out and reboot rocketchat everyday

Hi,

Description

Everyday, I need to restart rocketchat because after severals hours, I cannot send messages. After reboot all works fine.

Server Setup Information

  • Version of Rocket.Chat Server: 5.4.1
  • Operating System: Ubuntu 22.04
  • Deployment Method: docker (nomad, consul)
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 14.19.3 - x64
  • MongoDB Version: 4.4.15 (Can’t upgrade to version 5, don’t have AVX flag on CPU)
  • Proxy: traefik
  • Firewalls involved: ufw (disabled for tests)

Any additional Information

After severals hours I have this message:

{"level":50,"time":"2022-12-20T07:33:07.214Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:33:27.215Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:33:47.215Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:34:07.216Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:34:27.216Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:34:47.218Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:35:03.275Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"Exception while invoking method autoTranslate.getSupportedLanguages","err":{"type":"errorClass","message":"Auto-Translate is disabled [error-autotranslate-disabled]","stack":"Error: Auto-Translate is disabled [error-autotranslate-disabled]\n    at MethodInvocation.autoTranslate.getSupportedLanguages (app/autotranslate/server/methods/getSupportedLanguages.ts:11:10)\n    at MethodInvocation.methodsMap.<computed> (app/lib/server/lib/debug.js:74:34)\n    at maybeAuditArgumentChecks (packages/ddp-server/livedata_server.js:1885:12)\n    at packages/ddp-server/livedata_server.js:1803:15\n    at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1257:12)\n    at packages/ddp-server/livedata_server.js:1801:36\n    at new Promise (<anonymous>)\n    at Server.applyAsync (packages/ddp-server/livedata_server.js:1800:12)\n    at Server.apply (packages/ddp-server/livedata_server.js:1739:26)\n    at Server.call (packages/ddp-server/livedata_server.js:1721:17)\n    at Object.post (app/api/server/v1/misc.ts:554:27)\n    at app/api/server/api.js:463:96\n    at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1257:12)\n    at Object._internalRouteActionHandler [as action] (app/api/server/api.js:463:39)\n    at Route._callEndpoint (packages/rocketchat_restivus/lib/route.coffee:150:32)\n    at packages/rocketchat_restivus/lib/route.coffee:59:33\n    at packages/simple_json-routes.js:100:9\n => awaited here:\n    at Promise.await (/app/bundle/programs/server/npm/node_modules/meteor/promise/node_modules/meteor-promise/promise_server.js:60:12)\n    at Server.apply (packages/ddp-server/livedata_server.js:1752:22)\n    at Server.call (packages/ddp-server/livedata_server.js:1721:17)\n    at Object.post (app/api/server/v1/misc.ts:554:27)\n    at app/api/server/api.js:463:96\n    at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1257:12)\n    at Object._internalRouteActionHandler [as action] (app/api/server/api.js:463:39)\n    at Route._callEndpoint (packages/rocketchat_restivus/lib/route.coffee:150:32)\n    at packages/rocketchat_restivus/lib/route.coffee:59:33\n    at packages/simple_json-routes.js:100:9","isClientSafe":true,"error":"error-autotranslate-disabled","reason":"Auto-Translate is disabled","errorType":"Meteor.Error"},"msg":"Auto-Translate is disabled [error-autotranslate-disabled]"}
{"level":50,"time":"2022-12-20T07:35:07.219Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:35:27.219Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}
{"level":50,"time":"2022-12-20T07:35:47.219Z","pid":1,"hostname":"e2fc1914a6d3","name":"System","msg":"No real time data received recently"}

Rocketchat env variables:

MONGO_URL="mongodb://127.0.0.1:27017/rocketchat?replicaSet=rs0&directConnection=true"

MONGO_OPLOG_URL="mongodb://127.0.0.1:27017/local?replicaSet=rs0&directConnection=true"

ROOT_URL=https://chat.xxx.xxx

PORT=3000

DEPLOY_METHOD=docker

DEPLOY_PLATFORM=${DEPLOY_PLATFORM}

OVERWRITE_SETTING_Show_Setup_Wizard=completed

IGNORE_CHANGE_STREAM=true

Mongo env:

MONGODB_REPLICA_SET_MODE=primary

MONGODB_REPLICA_SET_NAME=rs0

MONGODB_PORT_NUMBER=27017

MONGODB_INITIAL_PRIMARY_HOST=127.0.0.1

MONGODB_ADVERTISED_HOSTNAME=127.0.0.1

MONGODB_INITIAL_PRIMARY_PORT_NUMBER=27017

MONGODB_ENABLE_JOURNAL=true

ALLOW_EMPTY_PASSWORD=yes

Thanks!

Hi!

Have you tried using the oficial docker compose?

Oh! I never received notification of this answer, very sorry.

Yes and No, I followed and adapt to nomad orchestrator.

Since your answer, I found an ugly solution, cron to restart docker every night. :pensive: