Jitsi Meet intergration: Camera is "disabled" by default - How can I change the default setting to "enabled"?

Just a quick question:
Jitsi Meet intergration: Camera is “disabled” by default - How can I change the default setting to “enabled” ?


I tried looking into this, and was not able to get some more infos :grimacing:

But you keep looking for it please ? It’s annoying that colleagues always forget to turn on their camera. That wouldn’t happen if it was on by default.

I am not sure, but that looks like a privacy concern.

And this is the desired behavior, as of now. I was able to trace it back to this line:

What would be interesting, as a feature request, is to maybe remember this configuration on a global or per channel scope.

But as of now, this is the intended behavior.

Is it worth to change this file in our system ?
The file is located here:
And cam is on false.

It’s not that easy. hehehe

There is a whole building process involved.

But past that step, that’s the file you should change :wink:

So, there isn’t a quick solution ?
As the basis of a feature request, I would see that the setting is configurable.

You could try using the Custom JavaScript to change that setting, but I am not sure how to do that… or if that’s even possible using this customization feature :grimacing:

But that would be a first try.

Which customization feature do you mean ?



Custom Scripts

This behaviour is totally annoying. Why do I have to enable my camera dozens of times a week ?!

Especially since Jitsi has its own lobby screen (which spoiler: can be turned on and off by configuration):

But this screen gets completely skipped by rocket.chats config parameters that are being suffixed behind the jitsi url:

&config.callDisplayName="room Name"
&userInfo.displayName="Forename and Surname"

Why are you forcing those settings even if people just want to use Jitsi and its own basic functionality?

This really needs to be something which can be turned off in the Jitsi App Settings.

Is it possible the edit these rocket.chats config parameters ? So I can enable the camera by default ?
Where is this config located ?

No that’s the problem. The App integration doesnt allow those hardcoded parameters to be modified.

The only “simple” solution would be to put something like a proxy server between Rocket.Chat and Jitsi where you could cut all parameters behind the Hashtag out of the request url (#config.desktopSharingChromeExtId=“”&config.callDisplayName=“room Name”