Issues with a fresh installation of version 1524


#1

I have just downloaded and installed latest Rocket.chat using SNAP tool on Ubuntu (16.04 LTS). Overall, I had a smooth experience of installing and getting started with Rocket.chat. However, I did find a few serious issues.

Activating privacy features… 2018/04/24 17:58:09 open /root/snap/rocketchat-server/1254/.caddy/acme/acme-v02.api.letsencrypt.org/sites/<MY_DNS_NAME>/<MY_DNS_NAME>.crt: no such file or directory

  • The second issue is with start video chat using webRTC. When I clicked on it, nothing happened. I am using Chrome browser and tried to start video chat on several devices. All the Chrome browsers have passed the webRTC tests. I don’t know why video screen is not shown.

  • I signed in with open.rocket.chat and compared the differences between my installation and the official site. When my browser points to open.rocket.chat site, the videochat does not work either. It does show the video window, but only displays only myself, not the remote member. Note to experiment, I signed up with 2 accounts to simulate 2 members chatting.

  • Also I downloaded the Android Rocketchat client. However, I couldn’t find the start video chat option. Is it true that video chat is unavailable yet on the Android client?

To summarise, we have the issue of setting up auto SSL with Caddy, and using video chat (webRTC). It could be that I missed a few basic configurations on my environment. Other functions like text messaging works fine.

We are deciding whether we should use Slack/CometChat for our instant messaging solution. It seems RocketChat has all the features we want, but it is a pity we couldn’t get it to work completely.

Appreciate someone can guide me in this.

zlc


#2

I did some investigations on these issues, and have made some progress. I’d like to share my findings. However, I still have a few issues unresolved.

Caddy service failed to start
Using self-signed certificate and defining the domain name in /etc/hosts, I can get Caddy service to start and https to work. My guess is that the domain name I used, even it is registered with a DNS provider, has no CNAME record, and is not mapped to any IP address. Letsencrypt therefore is unable to create a SSL certificate for my domain name. It would be nice if the RocketChat documentation can make it clearer.

open.rocket.chat WebRTC-based video chat not working
after I used another Windows machine, the video chat is working. Presumably my previous computer does not have the latest Windows update. But I am glad with open.rocket.chat site, every features I tested are working.

On my self-hosted Rocket-chat (i.e. computer at home), however, the video chat is still not working. When I clicked on “start video chat”, no video screen is launched on my browser window. On the remote browser (which was used for simulating conversation partner), there is a notification (xxx invites you to video chat, do you accept?), I clicked on “Yes”. Again nothing happens on the remote browser. The only issue I can think of is that I didn’t use https to connect to the self-hosted Rocket-chat. Because I am using several computers in my home wireless network. I only use http://192.168.0.3:3000 to point to the chat server. I am wondering if secure connection is required in order to use video chat?

On the Android Rocket Chat app, I couldn’t find any links to start a video chat, nor can I receive any video chat invite. Is it by design or a defect?

Hope someone can enlighten me on these issues.

regards
zlc


#3

I made further investigation as to why webRTC does not work on my self-hosted Rocket-chat instance. It is related to secured connection. There is a relevant discussion in the RocketChat forum:

Basically, the connection to the Rocket.chat server must be secure for WebRtc to work. After I configure Caddy to support HTTPS listening on Rocket.Chat (currently using self-signed certificate), WebRTC works. It would really help users if the documentation can make this clear.

Now the remaining issue for me is to figure out if Android Rocket Chat app supports Web RTC.