Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

Is LDAP sync supposed to be broken in 4.0.x?

Description

I’m running a RocketChat instance on CentOS, recently upgraded from 3.18 to 4.2.1.

The upgrade went fine but the LDAP sync doesn’t seem to be working correctly. We use a standard issue Windows 2016 domain Active Directory Environment. When I run “Test Connection” and “Test User Search” both work fine with no errors.

When I run “Sync Now”, I get a message that the sync is running, but it doesn’t seem to pull in any new users. Before the upgrade typically I’d run the sync and then be able to add users to room even if they hadn’t logged in yet. Now I’m getting no additional users showing up when I run the sync.

Existing users are working fine.

Server Setup Information

  • Version of Rocket.Chat Server: 4.2.1
  • Operating System: CentOS 7.x
  • Deployment Method: Manual
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: 12.22.1
  • MongoDB Version: 3.6.22
  • Proxy:
  • Firewalls involved: None (used internally)

Any additional Information

We are not using encryption at this time. We do have a search filter setup so that only users in a certain Active Directory group will be imported. This is correct as far as I can tell and hasn’t changed since before the upgrade.