Is it an OS setting issue or a DB issue?

I’m using Rocket Chat as a virtual image of Ubuntu on Windows Server.
When I run the server for the first time, it boots to the environment I set up for the first time, and after rebooting, Rocket Chat with the settings completed is started.
It is being used as if there were two DBs.

I always want to use the latest rocatchat whenever booting, but I don’t know where to start and what to check. Is there a way to fix this problem?

I’m currently using the following method because of this problem.

  1. Run the Rocatchat image in the background in Windows Scheduler for the first time.
  • At this time, the setting is not the latest setting.
    Status) Number of registered users 2, no other setting changes.
  1. After the first boot is completed, reboot by executing the shell file registered in root’s crontab.
    [Command registered in the shell.]
sudo systemctl stop rocketchat
sudo systemctl stop mongod
sudo systemctl stop snap.rocketchat-server.rocketchat-server.service
sleep 5
sudo shutdown -r now
  1. When booting is completed through step 2.
    The settings when the final settings are completed are applied.
    Status) Number of registered users 10, domain change, settings such as user account policy completed.

Hi! welcome to our forums!

I suggest to try our docker deployment. it’s easier to maintain and you will end up with a deployment pretty much similar to the majority of our community.

In order to check for the latest version, go to ADMIN, it will be there:

You have a problem with your deployment and/or environment. You doesn’t need to reboot all those times, and the changes to the DB should be there after reboots.