How to make all public channels visible to anonymous & registered users in the left sidebar?


I have 25 public channels that I need to be visible to the user since the first time he opens my chat server. I have enabled allow anonymous read, however, when anonymous acc opens the chat server, he only sees the channel which has “default” option enabled in the left sidebar. If anonymous user clicks the search icon, then he sees the full list of public channels, but this is not ok. I want him to see all public channels immediately.

The same thing is with registered user. By default he sees only default channel. And I cannot make >1 default channel. Although I could create a bot to auto-add all users to all public channels, so this is resolvable easily.

But with anonymous it’s not. What can be done?

Server Setup Information

  • Version of Rocket.Chat Server: 4.3.2
  • Operating System:
  • Deployment Method:
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy:
  • Firewalls involved:

Any additional Information

Hi! Just did a test.

Marked to allow anonymous read (Admin > Account) and marked default_channel as default at (Admin > Rooms)


it worked as expected.

This is weird. Is your rocketchat server the same version?
I noticed that the channel can appear in sidebar after clicking search icon → selecting channel.

Can you try creating new channel in one browser, while having chatserver opened anonymously in other browser? Then in my case the new channel doesn’t automatically appear in anonymous user’s sidebar.


After just creating a new channel and setting it to default, it was not showing to the anonymous user already active. Even after reloading.

I had to login with a user, logout, and then enter as anonymous again.

Then it appeared.


@dudanogueira ok it appears that it’s possible to set a 2nd default channel in admin screen. In channel edit modal, an option to set default is not visible (I think if there is already a default channel)?

So then it’s a fixed issue, I can just make all channels default and it’s ok.

1 Like

I was able to check the flag for different channels as default.

The channel must no be private

This doesn’t work for me for some reason.
I can’t find anything in the documentation that would help me either.

Do you need tos ee some screenshots or something to help me?

What version are you running?
I tested this on latest versions.