How to disable 2fa?

I just updated to 4.4.2 and am getting prompted for 2fa on my android app. How do I disable 2fa for all users?
Also, I am not getting the email that contains the code for the 2fa. I do not have an email server set up so is that email supposed to be coming from the rocket.chat servers?

UPDATE: OK, I am logged into my user (an admin) on my computer. I found the “Security” section for my account. And I see that the option to “Disable two-factor authentication via Email” is available. But… it appears I need to send an email for that. Like I said I don’t have an email server set up. How do I disable this w/o an email?

UPDATE: I enabled TOTP and was able to log in on my phone via that. But I don’t want any 2FA. Its just a family server. However, now I am concerned about disabling it because it could be enabled again in an update in the future (it appears to have happened with this update) and I guess I was lucky I was able to log in w/ my computer when my phone required the 2FA.

Hi!

Please, try going into:
ADMIN > ACCOUNT > Two Factor Authentication > Disable

this should disable 2fa for all users.

1 Like