Google SMTP for the email

Description

I am unable to setup the email SMTP via Google domain. I did remove 2FA and enable pop3 and imap in the gmail settings. I also enable the settings for unauthorized app auth in the google admin console.
Everything seems to be working fine, but it doesnt send any emails at all.

Server Setup Information

Rocket.Chat Version: 3.13.2
NodeJS Version: 12.21.0 - x64
MongoDB Version: 3.6.14
MongoDB Engine: wiredTiger
Platform: linux
Process Port: 3000
Site URL: hidden :slight_smile:
=ReplicaSet OpLog: Enabled
Commit Hash: 5e9f4bc424
Commit Branch: HEAD

Any additional Information

Logs:
I20210429-15:21:42.127(-4) Updating process.env.MAIL_URL
I20210429-15:21:44.542(-4) The $MAIL_URL is ‘smtp://…:465’. You probably want ‘smtps://’ (The ‘s’ enables TLS/SSL) since ‘465’ is typically a secure port. undefined

Also these are my smtp settings:

Protocol: smtp
Host: smtp.gmail.com
Ignore TLS and pool activated
port: 465
username: the entire email with @
Password: same as gmail
From Email: Not sure, I put admin@csbtech.ca, that section was a bit confusing.

You will need secured Email for Gmail - smtps

So either port 465 or 587 with ignore TLS False

Username is you Google username, and your email is the actual email From address

So you might be joe.blogs@gmail.com

You can actually login to Google as ‘joe.blogs’ but your From address will be ‘joe.blogs@gmail.com’