Problems with setting up SMTP email

Description

I’m having trouble getting sending email though SMTP to work. (I have no problems with gmail or several other email clients connecting to our email server.)

The settings are set as:
Protocol: smtp
Host: ***
Port: 587
IgnoreTLS: off/false
Pool: off/false
Username: ***
Password: ***
From Email: ***

In the logs, the error I’m getting is:

Exception in defer callback: [Error: 140213872211840:error:1425F102:SSL routines:ssl_choose_client_version:unsupported protocol:../deps/openssl/openssl/ssl/statem/statem_lib.c:1929: ] {   library: 'SSL routines',   function: 'ssl_choose_client_version',   reason: 'unsupported protocol',   code: 'ESOCKET',   command: 'CONN' } 

Anyone have any ideas of what could be the cause of the problem?

Server Setup Information

  • Version of Rocket.Chat Server: 3.0.7
  • Operating System: Centos 7
  • Deployment Method: manual install
  • Number of Running Instances: 1
  • DB Replicaset Oplog: enabled
  • NodeJS Version: 12.14.0 - x64
  • MongoDB Version: 4.0.17
  • Proxy: haproxy
  • Firewalls involved:

Any additional Information

I followed the installation guild: https://rocket.chat/docs/installation/manual-installation/centos/