The Great Open Source Debate with Elastic, Gluu and GitHub 🎤 Oct 27

Error Register Workspaces Cloud


My server is not synchronizing with the cloud environment. Authorization error is displayed. What process should I perform to correct this failure?.

Server Setup Information

  • Version of Rocket.Chat Server: 3.8.1
  • Operating System: ubuntu server 20.4
  • Number of Running Instances: 1
  • DB Replicaset Oplog: No
  • NodeJS Version: 12.18.4
  • MongoDB Version: 3.6.14

Any additional Information

Integration was active and working, but after updating it stopped working. I tried to register again manually, but without success.

Can you give this a try? We had a bug in the oauth process that is now resolved

I appreciate the feedback. But the failure still remains. Errors present in the image below. We even tried to remove it from the cloud and register with a new server (excluding the old one), but it returns the same failure, just as it happened with the server already registered in the cloud environment. Is it possible to register this environment as a new server?

?What is the solution?

What is the solution?


Ok. What version of Rocket.Chat are you on?

The environment is updated whenever a new version is released. However, we were unable to synchronize with the cloud console to register (Server has already been registered).

So you are using a snap, correct?

And external access all works OK?

  • List item Então você está usando um snap, correto?
    Yes correct.

  • List item E o acesso externo funciona bem?
    We had no problem with external accesses, the SSL option is active and without fail. We perform access by browser, smartphone app and desktop app.

Ok - thank you.

Can you leave it with me as I need to go and check a few things.

I will get back to you as son as possible and see if we can get you running.

Hi - I have messaged privately you as I need some private information so we can try and re-generate the key for you.