Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

digitalOcean new installation not quite working

A few months ago I tried rocket.chat on digitalOcean, all was fine. So, after a quick test I removed this app back then.
Now I’m trying repeat same steps and it’s not quite working:
initial install is fine and I can open app by IP and I can see setup-wizard. After that I updated my old A record chat.myserver.something to my new IP
and I run command in the console
rocketchatctl configure --lets-encrypt --root-url=chat.myserver.something --letsencrypt-email=myemail
and after that chat.myserver.something isn’t loading, and in the browser console I see errors:
4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:732 Mixed Content: The page at ‘https://chat.myserver.something/home’ was loaded over HTTPS, but requested an insecure resource ‘http://[IP number]:3000/meteor/dynamic-import/fetch’. This request has been blocked; the content must be served over HTTPS.
p @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:732
(anonymous) @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:732
(anonymous) @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:1
Promise.then (async)
n.then @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:728
t.fetch @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:732
(anonymous) @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:3
(anonymous) @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:3
(anonymous) @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:1
Promise.then (async)
n.then @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:728
d.prefetch @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:3
b.dynamicImport @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:732
(anonymous) @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:997
a @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:1
u @ 4570baead5d2268f7b1b9130e7a3050a0f9cb32a.js?meteor_js_resource=true:1

Hi, and yes we’re aware of that. This is not related to DO, but Rocket.Chat, I believe there are tickets open as well.

I’m not yet sure what is wrong. Haven’t had the time to dive deeper as well :frowning:

I’ll get back tomorrow.

Thanks.

Is there any progress?
I cannot find any recent open/closed ticket with similar looking description, can you point me to any?

I tried to update to 4.2.2 - now upon page load I see login popup. When I entered my credentials I still see same kind of errors in browser console and nothing shows in webpage

1 Like

Hey ,
same issue here.
Running into same issues and also can’t find related tickets…
Would be grateful to receive help.

Same issue here.

Is this a config issue?

Would changing a env var help?

Yes! Yes, indeed.

A simple config solved this problem.

Step 1: open /lib/systemd/system/rocketchat.service in a text editor.

Step 2: edit these 2 lines as follows (be sure to replace yourdomain with your actual domain):

Environment=ROOT_URL=https://chat.yourdomain.com
Environment=OVERWRITE_SETTING_Site_Url=https://chat.yourdomain.com

Step 3: Restart sudo shutdown now -r (I first tried systemctl restart rocketchat but it did not seem to do anything)

Now I am getting the setup wizard as expected!

1 Like

@Berserque @yureckey

Lmk if this helped you out!

Nice catch, aylabbs, I did it and I see no errors in console now and normal interface. Yay!
Did you just run text search on all the files or there is some documentation mentioning that?
Thanks a lot!
But I’m sad - it was 12 days since I posted this, I wish anybody from rocket.chat team did something that would actually help…
As I see it - if I choose to use this software, even using recommended guides, if anything happens with my setup, it’s pretty much on my own and no help from the team.