Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

Can't find "Users must use Two Factor Authentication" Option

Description

Hopefully this is an easy one. I am trying to force 2FA (email) on all of my users. I have read elsewhere that there should be an option for this in “Permissions”, however I can’t find it anywhere. Has the location of this setting changed in recent versions?

Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System: 3.18.3
  • Deployment Method: Snap
  • Number of Running Instances: 1
  • NodeJS Version: v12.22.1
  • MongoDB Version: 3.6.14 / wiredTiger (oplog Enabled)
  • Proxy: Caddy
  • Firewalls involved: Yes

Thanks in advance!

I am not sure about it being in permissions as I can’t find it myself. I know in Administration > Accounts > Two Factor authentication you can force it there.

Is this what you were looking for?

Thanks for the reply moesestt,

The place where I saw mention of the “Users must use Two Factor Authentication” in “Permissions” is here:

I have already configured the options of Administration > Accounts > Two Factor authentication to Enable Two Factor Authentication, Enable Two Factor Authentication via Email, and Auto opt in new users for Two Factor via Email.

What I want to do is force every user (existing and new) to use Two Factor Authentication via Email. The Auto opt in new users for Two Factor via Email option only applies to newly created users, not existing users.

Thanks!

I found only one more thing that may be of use.

In Administration > Permissions if you click on the pencil next to the role name it will open up a side screen. This has an option to enable Users must use Two Factor Authentication.

I wonder if this is what you were looking for.

1 Like

Moesestt,

That is exactly what I was looking for! I didn’t notice that was an editable option.

Thank you very much!

1 Like