Can't connect to self signed certificate https server using Android app

I deploy a rocketchat server on my vps server.

I created a self signed certificate with Custom Root CA and configured it in nginx config file.

And I configured a SSL Reverse Proxy using nginx.

Because I don’t own a domain name,I use IP address to visit rocketchat server.For example,https://

Now I can visit rocket server successful with web browser and desktop app.
I can’t connect to server with android app using https.(https://
Error message is “An error has occurred while checking your server version,please try again.”
But I can connect while using http.(http://

Android apk is downloaded from github release.And I installed version3.3.0.

Rocketchat server version is 0.74.3.
Android version is 8.0.0.

Can you please help me to resolve this problem?

1 Like

Why is there still no way to accept a self-signed certificate?


Me too. Note that if you install DSoftChat, then this app accepts https://… server address and login account successfully, but the official Rocketchat app shows error Invalid URL ….

Hi all, I have same error.

Hey i am also facing the same issue @rafael.kellermann @aaron.ogle could you guys please help me

You are using the latest version of the app?

Currently, self-signed certificate works on iOS only.
We’ve been working on Android support, but it’s not finished.
We need to test it properly.
Feel free to contact me on and I’ll send you an apk so you can try it on your server.
I’m @diego.mello there.

It looks like DSoftChat is a fork of our app.
Is it works on their app and not on ours, it’s probably because they implemented and never contributed back to us.

Dear Diego Mello

Please the apk so that i can check

Thanks & Regards,
S Surendra Babu,
Network & System Administrator.

Hello. I found this thread in my search for a solution to a similar problem. I was using Rocket Chat on a private IP address, with a mix of local and remote users. I wanted to implement HTTPS - which seemed to work for my Windows/Linux users, but not for Android users.

In following up with Diego.mello, he indicated the update ( was going live that day, and I could try it again.

At first - I didn’t have the expected success, even when I put the self signed CRT onto my Android device. But, with followup with the dev person involved, and upon closer examination of the warnings I was seeing in browsers (android, windows, etc …), I realized I had not properly established my CRT/KEY, and I wasn’t using DNS to access the service - which was required for the Android App.

I followed this link to re-issue my CA/CRT/KEY with the DNS name, modified the local DNS server to provide a FQDN to use, and with the Android 4.7 version of the app, was able to connect to my private server with HTTPS. (

Note - I’m using an NGINX reverse SSL proxy to encrypt the remote access, and proxying to the local server running on port 3000.

Configuration: Centos 7.8 (2003), nginx 1.16.1-1, rocketchat server 3.0.4 .

Many thanks to the RC team for providing quick access to the update, and the follow-up.

Please send me the apk so that we can test and use


I have the same problem we can’t connect android rocket chat app with my custom https server which is working based on IP address and we set self signed certificate any one help us?