RocketChat Andorid app certificate error

Description

I was testing out rocketchat on android. I ran into the issue where I get the error message:

java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.

I read a few other issues where this popped up on an older version of rocketchat but nothing recent. None of the older ones were solved.

I do try and click on the Apply Your Certificate link but it does nothing.

Server Setup Information

  • Version of Rocket.Chat Server: 4.6.2
  • Operating System: ubuntu 20.04
  • Deployment Method: Manuel
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 14.18.3
  • MongoDB Version: 4.4.13
  • Proxy: nginx
  • Firewalls involved: none

Android Info

Model: Pixel 4XL
Android Version: 12
Rocketchat app ver: 4.27.1.32281

Any additional Information

I am amble to connect using the browser on the device but the app does not work.

Hi, i had the same problem wheni use my own certificate with caddy.
I would have to deploy the crt certificate on the mobile device ; PEM and KEY was declare in the caddy file.
But, it’s NOT a godd solution for people outside my company ; so i use the letsencrypt and auto renew certificcate (which doesn’t works since 2 week …)