Can not install any app from marketplace



When i install any from marketplace i get a error “Invalid purchase type”
I have reconect to the Rocket.Chat.Cloud but it doesnt work.
How can i solve this problem? Thanks in advance for helping:)

Server Setup Information

  • Version of Rocket.Chat Server: 4.4.2
  • Operating System: Rocky Linux
  • Deployment Method: Manual
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version: v14.18.2
  • MongoDB Version: 4.0.28 / mmapv1 (oplog Ingeschakeld)
  • Proxy: NGINX Reverse Proxy
  • Firewalls involved:

Any additional Information

{“level”:35,“time”:“2022-02-17T08:44:47.532Z”,“pid”:51820,“hostname”:“,“name”:”",“name”:“API”,“method”:“GET”,“url”:"/api/apps?buildExternalUrl=true&appId=2629d8c4-2c70-483c-92dd-c43a771d7d91&purchaseType=&details=false",“userId”:“2Ku9u6uBYHwRn829A”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.102 Safari/537.36”,“host”:“My.hostame”,“referer”:“TransIP - Reserved domain”:1}

Same Problem here running on docker

Hey, @huib and @jk-bakad!

Can I ask you to check again (in case you didn’t recently), please?

We found some issues regarding our deployment in Marketplace, that caused the same problem you describe with a couple of workspaces. But we already solved it and it’s working.

Thanks! :slight_smile:

Hi, i have already solved by another solution. Thanks for watching