Upgrade mongo from 3.4 to 3.6 with RocketChat 0.60.4

#1

Description

Hello,

I am running a Rocket chat server version 0.60.4 in Heroku using a 3rd part mongodb service. I have been contacted my the mongodb guys saying that they will not support 3.4 in future and they will migrate to 3.6 soon.

I wonder if everything will still work after migration. Do I need to upgrade my 0.60.4? last time I tried there were some issues and I had to downgrade because of some bugs that were preventing to make it work on Heroku, so I will really prefer do NOT update…

Server Setup Information

  • Version of Rocket.Chat Server: 0.60.4
  • Operating System: Ubuntu
  • Deployment Method: heroku
  • Number of Running Instances: 1
#2

I am not sure which version of Mongo that your very old version of Rocket will support. Someone else may know the answer to that.

Current stable version 0.74.3 will.

You are probably 14 versions behind now - so well over a year out of date, and the longer you leave it to update, the harder it is going to be. Trying to jump several versions is a really good route to trashing your DB.

I have no experience of Heroku but would suggest you get upgrading, with plenty of backups along the way. Note you cannot back up your DB, upgrade straight to another version, and then restore the DB. It has to be restored to the same version it was saved from. So a Rocket 0.60 DB needs to restore to Rocket 0.60

It’s going to be a long slow process, but please don’t put it off.

#3
  1. For sure backup!
  2. It should work with Mongo 3.6 just fine.

That’s a pretty old release. So definitely recommend looking into updating.

The heroku install is definitely a bit tricky to update. Its been a few years since i’ve actually done it. But if I remember right it was a git pull type operation.

#4

Than you for the answer.

The problem with heroku is that there is a bootstrap max time for a service: if a service takes more than 1 minute (if I well remember) to start then is killed by heroku. Heroku restart your service every 24h.

Version up to 0.60 bootstrap by 1 minute, versions after 0.60 take longer, making impossible to run roketchat on Heroku.

For this reason it was impossible for me to update Rocket on heroku. It was like that last time I tried ( I even open a github issue explaining the problem that didn’t get solution). I don’t know if something changed in the meanwhile.

#5

Can you tell us which github issue number it was? Someone may be able to take a look.

#6