Unable to add users to public channel, not showing all users


We have run into an issue where we create a new channel and then go to add users to it but the list ends at 10 users. We cannot see any users past this. Users can see the channel and join it manually but this is highly inefficient when we are trying to add a whole department.

This is even that case on “super” admin or our admin user with every permission.

To say when this started, it is when i upgrades from 4.X to 5.0.2

Steps to Recreate
  1. create a new channel
  2. Join channel (if not owner/creator)
  3. Click on members
  4. Click on Add
  5. Click on “Choose Users” dropdown
  6. See only the top 10 users, alphabetically
Picture of list cutting off

Server Setup Information

  • Version of Rocket.Chat Server: 5.0.2
  • Operating System: Ubuntu 20.04 LTS
  • Deployment Method: Manual
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 14.19.3
  • MongoDB Version: 4.4.15
  • Proxy: nginx
  • Firewalls involved: None

Any additional Information

This doesn’t appear to show in the logs as an issue. Though when i tried to create an invite link I get a red error box stating object Object.

object Object Error


Thanks for pointing that out!

If I recall, this this issue is to be solved in our upcoming 5.1.0 that should be released anytime soon.

If you want to test it on your staging environment, please, deploy Rocket.Chat using docker and change the tag to release-candidate

Also, please, consider joining us at our Beta Testers Channel and help us catch those bugs before release!


Edit: here is the release notes of the the most recent release candidate for 5.1.0

1 Like

I have updated the server to 5.1.2 and the issue still persists.

I checked my installation. I think I misunderstood the issue.

While it will only suggest 10 users, you can still search for other users.

Check this video: