Twitter OAuth problems

hi all, I’m trying to enable OAuth for Twitter but I receive an “undefined” red pop-up error when I’m using the Twitter icon that I have on my login page.
In the logs I see these errors:
{“level”:40,“time”:“2022-08-23T12:44:03.388Z”,“pid”:1199664,“hostname”:“rocketchat”,“name”:“System”,“msg”:“Automatically added ?close to ‘redirect_uri’ for twitter, this behavior will be removed in v5.0.0.
Please update your OAuth config to accept both with and without ?close as the ‘redirect_uri’.”} {“level”:50,“time”:“2022-08-23T12:44:03.904Z”,“pid”:1199664,“hostname”:“rocketchat”,“name”:“System”,“msg”:“Exception while invoking method login ‘’”}

I’ve tried to configure the OAuth Twitter settings in my Server settings for OAuth, but I don’t understand how to set correctly the Twitter Id and the Twitter Callback URL.
Twitter ID is the username that I’ve to use to authenticate? The same username that I’ve created on Twitter Developer page?
Twitter Callback URL is my server URL + /_oauth/twitter ?
Is my server listen on a specific post for HTTPS (eg. 2050) what I’ve to set?

Please let me know any “guide” or “how to” to enable Twitter Oauth.
I’ve checked online docs, unfortunately, there I don’t find so exaustive info about these settings.

Last, I’m “rookie”, then please excuse me for my “dumb” questions! :slight_smile: