The Great Open Source Debate with Elastic, Gluu and GitHub 🎤 Oct 26

SMTP does not work even though the message was sent successfully

I created DigitalOcean Droplet to have Rocket.Chat.
Everything is great until I install SMTP, It doesn’t seem to work, I tried Gmail SMTP, Sendgrid, Mailjet…

  • When i click send test smtp it says successfully sent (but i received no mail)
  • When I create a new account it says successfully sent (but not any mail to the mailbox)
    ==> What do I need to do to fix it

Hi.

Please read this and give us some background information.

Rocket version, how did you set it up etc etc

Make sure admin/Email/SMTP is correctly set up

When you send a test mail from the admin panel check the Rocket Chat logs.

Also check you server logs - firewalls etc.

  1. Ver: 3.14.0 (Install from DigitalOcean)
  2. Sure, I’ve tried gmail’s Smtp, Sendgrid, Mailjet.
  3. Error Logs Enabled

That’s out of date - latest is 3.18.1 so you need to upgrade.

What do they say?

You have not shown the server setup part - just the user login. We need to see that.

To debug just work with one provider instead of chopping and changing.

1 Like

I asked DigitalOcean for support and got SMTP working.
How to change Footer Mail

Cool. What had you missed?

Have a read of ALL the settings.

admin/Email/ Footer…