Sec_error_revoked_certificate / Reissue LetsEncrypt for snap Install


Since today i have this :SEC_ERROR_REVOKED_CERTIFICATE in firefox. and in any client.

i think i must reissue Lets Encrypt certificate for Snap install.
i tried this:

snap stop rocketchat-server.rocketchat-caddy

# in /root/snap/rocketchat-server/current
mv .caddy .caddy.bak

snap start rocketchat-server.rocketchat-caddy

but there is no .caddy

i have no idea, where i can begin…
please help
thank you in advance!
kind regards Alex

Server Setup Information

  • Version of Rocket.Chat Server: (I think its the latest 4…)
  • Operating System: ubuntu 20
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy:
  • Firewalls involved:

Any additional Information

Same problem here. When I go to the /current directory and enter mv .caddy .caddy.bak it says cannot stat ‘.caddy’: No such file or directory

Solution found here

go to where the SSL certificates are stored by Caddy (I dropped into a root shell with sudo su - first):

$ cd /root/snap/rocketchat-server/current/.caddy

And then renamed the acme folder, which contains the SSL certificate + key:

$ cd mv acme acme.old

Finally, I restarted caddy:

systemctl restart snap.rocketchat-server.rocketchat-caddy.service

This worked. Thanks for the help

1 Like

It works for me too! thank you !

1 Like

This worked thank you!

1 Like

Thank you!!! :slight_smile:

We really appreciate it

1 Like