The Great Open Source Debate with Elastic, Gluu and GitHub 🎤 Oct 26

SAML configuration - no Public Cert Contents option yet error says "you must specify both cert and key file"

Description

I’m attempting to configure SAML and my SAML admin view does not include a Public Cert Contents option. How do I “switch on” the Public Cert Contents option?

The documentation mentions a Public Cert Contents option

See the Rocket.chat SAML Server settings docs

What I see:
I get the Custom Certificate and Private Key Contents but not the Public Cert Contents option.

Server Setup Information

  • Rocket.Chat Version: 3.18.1
  • NodeJS Version: 12.22.1 - x64
  • MongoDB Version: 3.6.14
  • MongoDB Engine: wiredTiger
  • Platform: linux
  • Process Port: 3000
  • ReplicaSet OpLog: Enabled
  • Commit Hash: 73ab3c26a7
  • Commit Branch: HEAD
  • Proxy: nginx
  • Firewalls involved: ufw

More context… I’m getting an error message about a missing cert (which I figure is due to the lack of a public certificate, which I can’t add)

  server.js:204 steffo:meteor-accounts-saml ➔ error SAML Service: You must specify both cert and key files.

I’ve upgraded to Rocket.Chat 4.0.1, now I do see the Public Cert Contents but in 4.0.1 it seems the SAML Advanced section has been removed, which means I can’t control the Identifier Format.

See this. Don’t shoot the messenger please.