Rocketchat container not starting after docker restart

Hi. I am updating a bunch of Rocketchat instances that I am maintaining, but I run into issue in each one of them. When I update the mongo and rocketchat versions, the first time I run docker compose up -d the containers boot, Rocketchat successfully connects to mongo and the service is working fine.

However, after restarting the containers with docker compose down then docker compose up -d the rocketchat container starts but doesn’t boot up rocketchat. Below is the log from docker logs command indicating where it hangs. Please note that on the first boot (when it works fine), it still shows the same errors, but after that, it continues with establishing connections and running, but after docker restart it just hangs at this step.

docker logs rocketchat-1

strict mode: missing type "object" for keyword "additionalProperties" at "#" (strictTypes)
strict mode: missing type "object" for keyword "properties" at "#" (strictTypes)
strict mode: use allowUnionTypes to allow union type keyword at "#/properties/value" (strictTypes)
(node:1) NOTE: We are formalizing our plans to enter AWS SDK for JavaScript (v2) into maintenance mode in 2023.

Please migrate your code to use AWS SDK for JavaScript (v3).
For more information, check the migration guide at
(Use `node --trace-warnings ...` to show where the warning was created)
LocalStore: store created at 
LocalStore: store created at 
LocalStore: store created at 
MessageType.render is deprecated. Use MessageType.message instead. livechat_webrtc_video_call
{"level":40,"time":"2023-11-02T11:36:44.373Z","pid":1,"hostname":"a4b7a47107e9","name":"VoIPService","msg":"Voip is not enabled. Cant start the service"}

Server Setup Information

  • Version of Rocket.Chat Server: 6.3.10
  • Operating System: Ubuntu-22
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: ?
  • NodeJS Version: ?
  • MongoDB Version: 5.0
  • Firewalls involved: no

After further investigation, it turns out that this happens only after I import the mongo database dump from the old server. I am following this guide to perform the upgrade:

So i first export the old mongo database, then upgrade rocketchat and mongo versions and then import the database in the new server. However this prevents the rocket server from starting after containers are restarted.