Rocket chat snap install does not work


#1

Hello,

Server config: Ubuntu 16.04 server, 1GB RAM

I booked a server and installed rocket chat from snap. i tried IP_ADDRESS:300 and nothing happened.

I checked out the logs and there seems to be a problem with mongodb, I checked the logs and its shows this:

Was unable to connect to Mongo. Please make sure Mongo has started successfully: sudo systemctl status snap.rocketchat-server.rocketchat-mongo to view logs: sudo journalctl -u snap.rocketchat-server.rocketchat-mongo

then I tried

sudo systemctl status snap.rocketchat-server.rocketchat-mongo

and it shows this

snap.rocketchat-server.rocketchat-mongo.service - Service for snap application rocketchat-server.rocketchat-mongo
Loaded: loaded (/etc/systemd/system/snap.rocketchat-server.rocketchat-mongo.service; enabled; vendor preset: enabled)
Active: inactive (dead) (Result: exit-code) since Wed 2018-04-04 15:08:13 UTC; 38min ago
Process: 2314 ExecStart=/usr/bin/snap run rocketchat-server.rocketchat-mongo (code=exited, status=100)
Main PID: 2314 (code=exited, status=100)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable

I am stuck. Any help will be appreciated.


#2

Hi @karthik_ak!

Rather than Mongo’s service status, can you also post the actual logs?

You can view them by running sudo journalctl -u snap.rocketchat-server.rocketchat-mongo.

Jonas


#3

Hello @frdmn,

Thanks for taking pains to reply me. I am not sure what I did, but I restarted mongo I think and it seems to be working now (I don’t know how).

I did collect the logs yesterday, you may have a look here https://gist.github.com/mindaslab/8ec1f5dac0d0080bc0846a3755e595b3

Thank rocket chat community a lot for them to have given us this excellent software :slight_smile:


#4

The logs in your gist are just for the snap.rocketchat-server.rocketchat-server service rather than the snap.rocketchat-server.rocketchat-mongo one.

Anyways, if it happens again - try to collect those logs instead and post them here again. :+1: