Rocket.Chat Android App can't send text message to my Rocket.Chat Server


#1

Hi, I am new to Rocket.Chat. I deployed Rocket.Chat v0.66.3 to my own Ubuntu server using snap and configured it following the installation instructions. Web clients and iOS clients work well. However, the native Android client installed through Google Play has a problem. I can log in and receive messages. When I try to send a text message, it doesn’t show up in the channel. Following are the different things I tried.

. Users cannot send text message in native Android client connected to my own Rocket.Chat
. The same user can post files in Android client to a channel on the same server.
. iOS client and web client connected to the same server work flawlessly.
. When I connect the Android client to https://open.rocket.chat server, it works well.

So there must be something wrong with my own Rocket.Chat server. Can anyone shed some light?
Thanks,
Jeff


#2

I reinstalled Rocket.Chat to another server following the same Snaps installation instructions. This time it worked.