RC 0.65.2 works but not any 0.66.x


#1

Hello everyone. I’m running RC on a lxc container with ubuntu 18.04 (upgraded from 16.04) that worked fine with first installation (on this server) witch was RC 0.50. and upgraded with dev versions of RC and stable versions till 0.65.2. I’ve tried to upgrade from 0.65.2 to 0.66.0 rc0 and after rc1 0.66.0 stable and alt last 0.66.1. None of this versions worked. Reverting back to 0.65.2 RC is up and running …
The error is “502 Bad Gateway”. In rocketchat.access.log I have this error: “[error] 451#451: *1 connect() failed (111: Connection refused) while connecting to upstream, client.”
There is major change between 0.65 and 0.66 since I have not changed any configuration file?
Thank you for any answer!


#2

You might have had the migration error too. Try updating to 0.66.2 or try something similar to: Snap migration failed for 0.66.1 obviously will have to translate and connect to mongo how ever you do with lxc


#3

Thanks for your help. But after upgrade from 0.65.2 to 0.66.2 … same error (502 Bad Gateway). After migrate manually migrate mongodb with:

“rs0:PRIMARY> use parties
switched to db parties
rs0:PRIMARY> db.migrations.update({_id: ‘control’}, {$set: {locked: false, version:125}})
WriteResult({ “nMatched” : 0, “nUpserted” : 0, “nModified” : 0 })
rs0:PRIMARY> db.users.update({
… ‘settings.preferences.groupByType’: { $exists: true }
… }, {
… $rename: {
… ‘settings.preferences.groupByType’: ‘settings.preferences.sidebarGroupByType’
… }
… }, {
… multi: true
… });
WriteResult({ “nMatched” : 0, “nUpserted” : 0, “nModified” : 0 })
rs0:PRIMARY> ^C
bye”

… still no joy :confused:


#4

I’m guessing your db since not a snap install is not called parties. So what ever db you use in your MONGO_URL connection string is what you want to substitute parties for.

Most use rocketchat as the name of the db. Snaps are the only case that uses parties