Problem with Slack Import


#1

Hi!

I have the most recent snap installation of Rocket Chat - 0.61 and I wanted to import Slack data.
While users and channels are imported without any problems, the process stops at 1500/84000 and messages are not imported.
Importing ends with success status. This is what is in the logs.

[34mI20180612-08:29:27.660(2) Exception in callback of async function: Error: File exceeds allowed size of -1 B. [error-file-too-large]     at Filter.validateFileUpload [as onCheck] (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_file-upload.js:122:13)     at Filter.check (/snap/rocketchat-server/1273/programs/server/packages/jalik_ufs.js:595:53)     at FileUploadClass.insert (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_file-upload.js:640:14)     at res.on.Meteor.bindEnvironment (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_importer.js:391:19)     at runWithEnvironment (packages/meteor.js:1238:24)  
[34mI20180612-08:29:28.358(2) rocketchat_logger rocketchat_logger.js:278 e[31mSlack Importer ➔ error TypeError: Cannot read property '_id' of undefined     at Object.createWithTypeRoomIdMessageAndUser (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_lib.js:8010:19)     at msgs.messages.forEach.message (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_importer-slack.js:558:52)     at Array.forEach (<anonymous>:null:null)     at Object.keys.forEach.date (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_importer-slack.js:458:29)     at Array.forEach (<anonymous>:null:null)     at DDPCommon.MethodInvocation.Meteor.runAsUser (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_importer-slack.js:456:38)     at packages/dispatch_run-as-user.js:211:14     at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1186:12)     at Object.Meteor.runAsUser (packages/dispatch_run-as-user.js:210:33)     at Object.keys.forEach.channel (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_importer-slack.js:442:18)     at Array.forEach (<anonymous>:null:null)     at Meteor.defer (/snap/rocketchat-server/1273/programs/server/packages/rocketchat_importer-slack.js:440:36)     at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1186:12)     at packages/meteor.js:502:25     at runWithEnvironment (packages/meteor.js:1238:24) 

I have tried reinstalling, exporting slack data again, nothing works.
Do you have any pointers what can be the problem?


#2

You say 61 we are on 0.65.1 typo? Just checking before diving too far into it :slight_smile:


#3

Yeah, it’s a typo. Sorry.
Rocket.Chat Version: 0.65.1


#4

I’m not that familiar with slack import, but maybe try setting the file size limit super high during the import?


#5

That’s actually set when the import runs, according to the logic it was supposed to bypass the upload limit. @rodrigo.nascimento here is yet again another item of this, it needs to be fixed. https://github.com/RocketChat/Rocket.Chat/issues/10278


#6

@pglimos please add your details here: https://github.com/RocketChat/Rocket.Chat/issues/10278 when this bug is closed it should be resolved


#7

+1 here - our import from Slack stopped after 3/4 of the channels.
It’s too late for us now hence we already used the empty channels and reimporting/merging is not an option?


#8

Did it stop with the same error as above or a different error?