New user stuck at "Security" text after login

Description

New users cannot get into any default channel, but instead it stuck at blank page with “Security” message on the screen, but for the old users everything is working well, I’m not sure that remove “general” channel would cause this problem or not since I tried to recreate “general” channel and set it to public and default channel but still doesn’t work.

Furthermore, new users is able to access to rooms that they’ve joined by input the link directly to the browser, but if I let it load the page until finish it will display “Security” text on the screen again, to make it work I have to click stop loading page then it works but the sidebar is not showing up
( you guys might see it’s a little confuse you can check in the video below )

This issue happens in web and desktop app only works fine on mobile app

Server Setup Information

  • Version of Rocket.Chat Server: 1.1.1
  • Operating System: Ubuntu
  • Deployment Method: systemctl start rocketchat
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: 8.11.4 - x64
  • MongoDB Version: 4.0.3
  • Proxy: nginx
  • Firewalls involved: none

Any additional Information

none

What is your “First Channel After Login” set to in Administration > General . if that is set to a deleted channel that would make sense on why its not working. If its set to general or anything and you delete it and i think it will go to home whats configured under Layout.