Mobile Apps cannot connect


#1

I have been searching for a while and found some posts that had a similar problem, but nothing helped to fix my problem.

My server is running on https://chat.thisfro.ch (Let’s Encrypt, Apache reverse proxy). Desktop apps and server work perfectly. Android app can load messages, but not send. There’s a “Connecting in …” countdown, which keeps getting higher. iOS won’t connect at all.

Am I missing some configuration?

Thx for any advice!

Edit: Android v2.4.0, iOS v3.0.1, Server v0.66.2


#2

This message appears because your server do not support WebSockets, take a look:

curl -i -N -H "Connection: Upgrade" -H "Upgrade: websocket" -H "Host: chat.thisfro.ch" -H "Origin: chat.thisfro.ch" -H "Sec-WebSocket-Key: fVXESE8fjBMx8HheW0YlZQ==" -H "Sec-WebSocket-Version: 13" https://chat.thisfro.ch/websocket

HTTP/1.1 500 Internal Server Error
Date: Fri, 20 Jul 2018 14:22:27 GMT
Server: Apache/2.4.18 (Ubuntu)
Content-Length: 612
Connection: close
Content-Type: text/html; charset=iso-8859-1

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator at 
 jannis@thisfro.ch to inform them of the time this error occurred,
 and the actions you performed just before this error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at chat.thisfro.ch Port 443</address>
</body></html>

#3

Ok thanks, didn’t realize that. Where would I get started to enable this?


#4

Since you’re using Apache, you can start here: https://rocket.chat/docs/installation/manual-installation/configuring-ssl-reverse-proxy/#running-behind-an-apache-ssl-reverse-proxy


#5

I had already set it up with this guide, but doing it again resolved the issue (somehow).

Thank you very much!


#6

Awesome, glad it worked! :heart: