Latest RocketChat Snap - permanently loading (3 dots)

Try adding ubuntu-desktop then going to the admin page locally then change the site url to the ip address:3000.

I can’t open localhost:3000 locally using Ubuntu-desktop, I have 3 dots. After that, I changed the site URL with “sudo snap set rocketchat-server siteurl=http://IP.addres:3000” but it didn’t help. I also tried without port number in siteurl.

So just so I understand correctly your installation has not worked from the start correct.

Now I have a third VM with Rocketchat. The first one worked very well until the three dot problem occurred. But the next two didn’t work from the start. I install Ubuntu-desktop on all these VMs and I can’t open the site with http://localhost:3000 or http://ip:3000 (3 dots).

Have you tried installing with snap?

As i can understand, all of us here have the same issue having deployed Rocketchat using Snaps.

1 Like

I believe so, It has came back on my server and it was working perfectly. So I am not sure what is going on. Is there any paid support for this from anywhere?

Twice with snaps (the first one worked perfectly until the 3 dot issue occurred) and one manual install.

OK , here we go and I am not sure what is going on but after my issue came back, I was fighting this all day yesterday and finally it came back to life last night and here is what I done and not sure why it is working. I login into it locally on the server went to workspace , then setting, General and turn off these settings and it came back to life. I hope this helps until the issue is totally resolved.
Capture

Since the automatic snap update to version 6.4.5 yesterday it has stopped working and has returned to the three dots loop.

Same here, infinite loading despite it working fine for the last few months… @debdut.chakraborty any fixes for the infinite 3-dot loading screen? Both local IP as well as reverse proxy (which, as other users have stated in this thread, both worked fine for months) result in infinite 3-dot loading screens.

I solved the problem by reverting to the previous version 6.4.4, stopping automatic updates and restarting the service:
snap revert rocketchat-server
snap refresh --hold=forever rocketchat-server
service snap.rocketchat-server.rocketchat-server restart

This is happening to me on 6.4.5 - it was fine until today (15nov) after updating to 6.4.5 from 5.4.10 on the 9th.
I’m going to try switching to edge to see if it solves anything.

didn’t solve anything, still returns 500 on a post request to /meteor/dynamic-import/fetch

so this is kinda embarrassing. My /var was out of space. system is working fine now that i’ve cleaned up 7GB of old rocketchat backup files.


Today, after the latest update to 6.4.6 i was facing the 3 dots issue. I changed the settings for allowing “Invalid Self-Signed Certs” and the problem is now gone. I hope this fix will work for you too.

Anybody else still having this issue? It’s crazy how poor the QA is getting lately for RocketChat…

I can’t even seem to get my forum posts reviewed and unlocked, which have been flagged by their spam filter. I’m afraid they’re going to focus on enterprise only in the future.

same. We are giving up rocket.chat

Is there any update for this problem?
My admin account cannot login now :rofl: permanently loading (3 dots)