Issues with uninstall of Rocket.Chat

Hi - I’m facing the following issue:

–> I installed on an fresh installed UCS server (4.4-8 errata987) Rocket.Chat from the UCS app store
–> I played a bit with the new software and decided to uninstall Rocket.Chat to set it up once again with the experience I made
–> The uninstall via UCS web interface worked fine
–> I did a reboot and selected Rocket.Chat once again from the UCS app store
–> no error messages during installation - all looked good
–> I tried to logon via the Rocket.Chat web interface with the Rocket.Chat default password (because new fresh installation) - but logon failed
–> logon with my credentials from my first installation worked fine
–> I checked some settings an test users and channels in the Rocket.Chat admin web section - and it looked like as it has never been uninstalled

How can this be???

Do I have to do something in addition to force a real delete???

FYI: I uninstalled Rocket.Chat now once again via UCS web interface - and all the parts I can check via web interface has been gone (as before).

Any help is more than welcome

Link to the UCS help platform: Issues with uninstall of Rocket.Chat - Apps & App Center - Univention Help


Ironically we are just looking at updating the UCS installation.

I have no idea why this behaviour occurs as I am not familiar with the install/remove process but I will check and get back to you next week.

It is possible that this is because Rocket uses its own Mongo DB via docker and the data for that may be persistent. Removing a docker container doesn’t always remove the actual data.

I’ll let you know as soon as I can find out.