The Great Open Source Debate with Elastic, Gluu and GitHub 🎤 Oct 27

Images upload small - sometimes resize to normal but sometimes don't. Also when uploading multiple files, the same file just uploads multiple times


I’m not sure if I should create two topics as I am having two problems since updating to 3.18 and 3.18.1 didn’t resolve it.

Firstly, when uses upload images they are resized, almost as if displaying a thumbnail. 50% of users seem to be reporting that a few seconds after clicking the photo to see it full size, it never resizes so they just see a small, really blurry version of the intended image.

The other problem I have noticed since the same update is if users try to upload multiple files at once. eg they click + and locate 01.pdf, 02.pdf, 03.pdf and 04.pdf to be attached to their message - what happens is 01.pdf uploads four times, and the others do not upload.

Server Setup Information

  • Version of Rocket.Chat Server: 3.18.1
  • Operating System: iOS 12 on phone / Ubuntu 17.04 on VPS
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: 12.18.4
  • MongoDB Version: 4.0.21
  • Proxy: nginx
  • Firewalls involved: none

Any additional Information

As mentioned above this was not noticed as a problem prior to 3.18 so I assume it’s related to that.

we released a new feature on 3.18 to show thumbnails from image uploads, saving bandwidth from the server when serving those image, but most importantly saving bandwidth and memory from mobile devices since they’re lower resolution images. unfortunately the mobile app could not released a compatible version in time, that’s why you see blurry images instead of the full resolution ones when opening them…

this will be fixed in the upcoming next mobile release…

in the meantime, you can disable this new feature going to Admin page > Message > Message attachments…

I’m not sure about the multiple uploads issue, may I ask you to open an issue on our git repository?

Bug already opened by someone I think

1 Like

in the meantime, you can disable this new feature going to Admin page > Message > Message attachments

This fixed it, thanks. Hopefully it is fixed soon and I can switch the bandwidth saving option back on.

Bug already opened by someone I think

Yeah that sounds like it, hopefully it will be fixed soon.


1 Like