How can I disable register username window and use default username automatically

Hello friends,

I integrated rocket chat with keycloak.

When I created new user in keycloak and trying to login to the rocketchat, register username popup is shown to declare a username to the new user.

But I want to do this process automatically so need to disable this popup. It should have given default username which is written into the related input.

I already set the settings as Administration > Accounts > Registration > Registration Form as Disabled
But it is not working well.

Is there any way to disable this popup ? Anyone has information ?
Thank you

The problem is solved.

I have this same exact problem. What was the solution?

Though my setup I’m sure is different. I have two different sites/domains running WordPress. Each one has the MiniOrange OAuth Server 5.1 plugin installed, and they both call one chat server that is running Rocket Chat 6. and within Rocket Chat, I have the two custom OAuth clients running.

MiniOrange actually helped me get the integration running between the two. And that works.

Once the user goes to the RocketChat server, I have RocketChat configured to ask if they are “Logging In from www.domain1.com” or “Logging in from www.domain2.com”.

Once they click either option, I want them to go RIGHT INTO Chat, after they authenticate from WordPress to RocketChat.

Ideally they would also NOT get that pop-up to “Allow” or “Deny”.

But right now when someone goes from the two OAuth server Wordpress site, to the Chat server, they are first getting the “Allow” or “Deny” prompt, but after “Allowing” they then get the pop-up asking them to register a username. And this pop-up does pass the correct username from WordPress, but it allows them to change it, and I don’t want users to change it.

How do I stop the “Allow” or “Deny”? And how do I stop the “REGISTER USERNAME” from appearing, and just passing the username into RocketChat?

Thanks all.

image