How to disable "Register Username"

Hi all,

Hoping someone can help…

I have two different sites/domains running WordPress 6.2. Each one has the MiniOrange OAuth Server 5.1 plugin installed, and they both call one chat server that is running Rocket Chat 6. and within Rocket Chat, I have the two custom OAuth clients running.

MiniOrange actually helped me get the integration running between the two. And that works.

Also once the user goes to the RocketChat server, I have RocketChat configured to ask if they are “Logging In from” or “Logging in from”.

Once they click either option (Login to or Login to, I want them to go RIGHT INTO Chat, after they authenticate from WordPress to RocketChat.

Ideally they would also NOT get that pop-up to “Allow” or “Deny”.

But right now when someone goes from the two OAuth server Wordpress site, to the Chat server, they are first getting the “Allow” or “Deny” prompt, but after “Allowing” they then get the pop-up asking them to register a username. And this pop-up does pass the correct username from WordPress, but it allows them to change it, and I don’t want users to change it.

How do I stop the “Allow” or “Deny”? And how do I stop the “REGISTER USERNAME” from appearing, and just passing the username into RocketChat?

Thanks all.