Google Auto Translate broken after update to 3.7.0, manual translate works


Previous Google auto translate worked for 3.6.0 and 3.6.3, on new 3.7.0 auto translate does not work but manually click on view original will translate the message to targeted language

Steps to reproduce:

  1. go to chat type whatever text, with pre setup auto translate to selected language,
  2. does not translate, only after i click on view original it will translate my text.
  3. auto translate is gone. manual translate is available.

Expected behavior:

When a user sends a text with their native language, auto translate will translate to the targeted language without needing to click on translate/view original

Actual behavior:

Server Setup Information:

  • Version of Rocket.Chat Server: 3.7.0
  • Operating System: Ubuntu
  • Deployment Method: Docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: v12.18.4
  • MongoDB Version:4.4.0

Client Setup Information

  • Desktop App or Browser Version:
  • Operating System: windows and android both same result.

Additional context

Relevant logs:

I20201004-06:37:15.442(0) LocalStore: store created at
I20201004-06:37:15.466(0) LocalStore: store created at
I20201004-06:37:15.466(0) LocalStore: store created at
I20201004-06:37:16.030(0) Setting default file store to AmazonS3
I20201004-06:37:18.027(0) (migrations.js:120) Migrations: Not migrating, already at version 206
I20201004-06:37:22.667(0) Updating process.env.MAIL_URL
I20201004-06:37:23.645(0) Using GridFS for custom sounds storage
I20201004-06:37:23.646(0) Using GridFS for custom emoji storage
I20201004-06:37:23.655(0) Loaded the Apps Framework and loaded a total of 4 Apps!
I20201004-06:37:23.976(0) ➔ System ➔ startup
I20201004-06:37:23.977(0) ➔ ±-------------------------------------------------+
I20201004-06:37:23.977(0) ➔ | SERVER RUNNING |
I20201004-06:37:23.977(0) ➔ ±-------------------------------------------------+
I20201004-06:37:23.977(0) ➔ | |
I20201004-06:37:23.977(0) ➔ | Rocket.Chat Version: 3.7.0 |
I20201004-06:37:23.977(0) ➔ | NodeJS Version: 12.18.4 - x64 |
I20201004-06:37:23.977(0) ➔ | MongoDB Version: 4.4.0 |
I20201004-06:37:23.978(0) ➔ | MongoDB Engine: wiredTiger |
I20201004-06:37:23.978(0) ➔ | Platform: linux |
I20201004-06:37:23.978(0) ➔ | Process Port: 3000 |
I20201004-06:37:23.978(0) ➔ | Site URL: https://locahost |
I20201004-06:37:23.978(0) ➔ | ReplicaSet OpLog: Enabled |
I20201004-06:37:23.978(0) ➔ | Commit Hash: 2c82cd9cee |
I20201004-06:37:23.978(0) ➔ | Commit Branch: HEAD |
I20201004-06:37:23.978(0) ➔ | |
I20201004-06:37:23.978(0) ➔ ±-------------------------------------------------+

Tried to remove the container and reinstall the rocketchat with the latest image, worked for the first 10 minutes using the old database, it will auto translate, after that auto translate stops, only manual translate. Google API sees the trigger. So google is setup correctly

#1 try - worked for 10 minutes
docker run -d --name rocketchat -p 3000:3000 --restart=always --link db --env ROOT_URL=http://localhost --env MONGO_OPLOG_URL=mongodb://db:27017/local

#2 try - did not auto translate
docker run -d --name rocketchat -p 3000:3000 --restart=always --link db --env ROOT_URL=http://localhost --env MONGO_OPLOG_URL=mongodb://db:27017/local --log-opt max-size=5m --log-opt max-file=10

All test are run with images removed. re downloading the container images from docker