Auto translation google api key not working


#1

Hi,

I have enabled auto translation feature. I have google api key in the JSON format. I want to configure the google API key in the message -> AutoTranslation -> GoogleAPIKey.

I tried to copy the JSON, private key from the JSON, privete key id from the JSON but it’s giving error:
“message”: “API key not valid. Please pass a valid API key.”

Can someone please help me to tell in which format I have to configure the google key.

I am using the same KEY in my other application and it’s working fine there.


#2

What version of Rocket.Chat?

Also after you save if you look at the key, do you see any special characters? Make sure not a bunch of spaces before / after it.


#3

I was using Google API key in Json format but when i used a String version of API key it’s working now.

But I found that the AutoTranslation feature is not available for LiveChat. To translate a particular message using ‘Toggle Original/translated’ option is available in LiveChat but the Auto Translation is not there.

Are you planning to support the Auto Translation fetaure for LiveChat also in upcoming versions ?

I am using version 0.65.1


#5

Feel free to open a topic in feature requests so this can be upvoted