First clean install - MongoDB 4.0 deprecation, update issues

Noob alert upfront :warning: :stuck_out_tongue:

I’m totally new to and this is also my first AWS EC2 deployment. It’s also the first time I’m using a Linux web server in earnest. I can follow Linux instructions but I’m far from native. I have worked with a few docker containers but never had to create one myself or even update it manually.

I managed to get RC running in docker (it works and is reachable) and was super happy. Then the mongoDB deprecation messages started in my clients and so I tried to update it and this is where things got tricky.

I first made the mistake to update mongoDB on the host Ubuntu OS. I followed the official, linked docu but there was no Mongo Shell update for 4.2.21. so it seems I’m now running mostly 4.2.21 but with a 4.0.28 shell.

Then I read that I need to update the docket compose y’all to fetch the mongoDB update so I did.

After restarting docker I now have an error that there’s a. Erosion discrepancy between server and shell.

Issue is, I don’t even know the info architecture here, are there two DBs, one in Docker and one on the host? If Docker reports the version issue, between which versions is this?

How can I fix it? Is there an easy way if I redeploy the container with a never version from the start?

Server Setup Information

  • Version of Rocket.Chat Server: 4.8
  • Operating System: Ubuntu 18.4
  • Deployment Method: Docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version: 4.0.23
  • Proxy: NGINX
  • Firewalls involved:

Solved, found the two version parameters in the compose file.