Fresh installation is using deprecated MongoDB version

I just installed RocketChat in Ubuntu server 21.10 using Snaps.

Installation command: sudo snap install rocketchat-server

Everything is working as expected except I keep getting the following message from

MongoDB Deprecated
MongoDB version 3.6.23 is deprecated, please upgrade your installation.

I also can see the warning on the app logs:

So my questions are:

1- Why an installation from scratch is deploying a deprecated db version? is this expected behaviour?

2- How I’m supposed to do to upgrade mongo? my understanding was that the snap refresh command should take care of it


Thanks for pointing that out!

cc @debdut.chakraborty

So, what is the fix here? I did the Docker install and it says that the 4.0.28 is deprecated on a brand new fresh install. I tried to edit the docker-compose to use mongo 4.2, but that failed miserably. There is not great documentation out there on how to install from scratch and not use mongo 4.0. Any help would be appreciated.

1 Like

@vmsman hi! Thanks for asking :slight_smile:

Updating the compose file has been slightly challenging because of how people tend to use them. I’ll create an intermediate repo to host it (new compose) in the meantime and let you know.

These are the changes to be made for the docker-compose in order to use 4.2 and wiredTiger:

We are doing some changes and improvements at deployment methods and documentation that should easy this process for all parties. Hang tight!


I updated my RocketChat to 4.6.1. It works great.
I decided to upgrade MongoDB 4.0.28 from nmap to wiredTiger.
Once I did that, no errors in the log. Everything looked great but not RocketChat web page.
I read where wiredTiger needs at least MongoDB 4.2, so I upgraded it.
No errors. Clean logs. Appeared to work, still no web.
Then I upgraded to 4.4 and finally 5.0.
So, I am at the latest of MongoDB now. The docker containers are stable.
However, no web interface for RocketChat. Good part is no deprecation errors anymore. Any ideas?


Can you try cleaning the cache?

Or try using incognito/private window, just to make sure.


Will the docker-compose.yml be updated? I get the deprecated error when creating a new workspace.

1 Like

Take a look at my video. Upgrading RocketChat in Docker - MongoDB 4 0 x Deprecated - YouTube