File uploads not working for my Mobile users

Rocketchat 4.4.1. I had to restore my image from backup. Prior, I had no issues. Now my Android/IoS users try to upload a picture. The upload progress bar progresses to the end and the error is “error, try again?”. I look in the log and I can see no errors. Uploads from the desktop client do work. The storage type is and always has been GridFS and has worked. I turned off Protect Uploaded files and still no difference. My Android version is 4.24.0.28002. This used to work.

hi!

What version have you upgraded from?

Desktop and Web versions work fine, this only happens in mobile, right?

I upgraded from 4.4.0. It seems that Desktop and Web updates are working and the Android and IoS versions act like they are getting the upload and then it just says “error” from the mobile client. I don’t have any log information to work from, so I am not sure how to diagnose the error.

I just upgraded to 4.4.2. Android and IoS users can’t upload images. Desktop users can. Seems like no one else has this issue at all.

Hi! Were you able to solve this or get more logs?

@dudanogueira Yes, I found a solution and posted it on my Discourse.

1 Like

So, after my mmap to wiredTiger migration, uploads freeze at 0% from both the desktop and mobile. I have a very standard docker install. Everything else works. I am at mongo 5 and the latest Rocketchat. Any ideas?